Service disruption
Incident Report for Xeno
Resolved
This incident has been resolved. Enjoy your new Inbox page :D
Posted Feb 13, 2020 - 12:46 UTC
Update
We are continuing to investigate this issue.
Posted Feb 13, 2020 - 12:17 UTC
Investigating
We are currently investigating. Service should be back in a few seconds. Thank you
Posted Feb 13, 2020 - 12:16 UTC
This incident affected: Web app (xeno.app).