Inbox under maintenance.
Incident Report for Xeno
Resolved
This incident has been resolved.
Posted Sep 16, 2020 - 09:31 UTC
Update
This issue is now entirely fixed in production. Our inbox page is back. Thank you for your trust and patience.
Posted Sep 16, 2020 - 09:30 UTC
Update
The issue is fixed in production. You may need to refresh your inbox page to see it. Some refresh may still not work for a couple of minutes.
Posted Sep 16, 2020 - 09:24 UTC
Identified
We are doing a product update, consequently our inbox is currently under maintenance.
Posted Sep 16, 2020 - 09:04 UTC
This incident affected: Web app (xeno.app).