Some issues with our login page

Incident Report for Xeno

Resolved

We are glad to let you know that this issue is now resolved. You may still be facing some slowdowns in the next few minutes. Thank you for your support! Have a great day!
Posted Jun 23, 2020 - 09:07 UTC

Monitoring

We are currently deploying additional servers. Situation should be back to normal very soon. Thanks
Posted Jun 23, 2020 - 08:39 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 23, 2020 - 07:40 UTC
This incident affected: Web app (xeno.app).