We are still having trouble with some of our servers

Incident Report for Xeno

Resolved

We are glad to let you know that this incident is now resolved. Thank you for your support! Have a great day!
Posted Jun 23, 2020 - 09:44 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 23, 2020 - 09:24 UTC
This incident affected: Web app (xeno.app).