Corporate website down
Incident Report for Xeno
Resolved
This incident has been resolved. Our corporate website xenoapp.com is back and fully functional. During this incident, the back-end of our product was not impacted a single second and was available from xeno.app, the front-end of our product (the chatbox) was not impacted a single second and was still available on your site(s) if deployed.

Thank you for your trust and thank you for being a Xeno customer!
Posted May 01, 2020 - 19:15 UTC
Investigating
The xenoapp.com corporate website is down. The product itself is still fully functional from the web address xeno.app. We are investigating.
Posted May 01, 2020 - 18:30 UTC
This incident affected: Corporate website..