Xeno corporate website down
Incident Report for Xeno
Resolved
This incident has been resolved.
Posted Jul 01, 2020 - 10:19 UTC
Identified
[No action is required from you]

The Xeno corporate website (xenoapp.com) is down.
This is not affecting the Xeno product (xeno.app) which is still fully functional.
You can still access Xeno from this page: xeno.app and use Xeno as usual.
For existing users and customers, there is No impact and No performance deterioration.

Thank you for your understanding.
Posted Jul 01, 2020 - 08:56 UTC
This incident affected: Corporate website..