Service Instabilities: Apologies for Any Inconvenience Caused
Incident Report for Xeno
Resolved
We experienced some slowdowns due to minor changes in our IT infrastructure. At present, everything is back to normal. We continue to actively monitor the situation. Thank you for your understanding.
Posted Jun 27, 2023 - 08:18 UTC
Identified
We are experiencing some minor service instabilities with our product, resulting in some slowdowns. We are working on the issue and kindly apologize for any inconvenience caused.
Posted Jun 27, 2023 - 08:14 UTC
This incident affected: Web app (xeno.app).